跳转至
For the complete DHIS2 documentation index, see llms.txt.

地图 - 事件和 TEI 层 - 会话摘要{ #maps-event-and-tei-layer-session-summary }

  • 在事件或被跟踪实体层中映射我们的数据需要在数据输入时收集坐标
  • 我们可以在跟踪器程序中映射事件,映射方式与使用事件层时映射事件数据的方式相同
  • 我们可以使用跟踪实体层映射跟踪实体。该层允许我们在同一程序中显示关系
  • 跟踪实体层也有一些局限性:
  • 我们不能将任何事件数据与被跟踪实体坐标结合使用
  • 无法在地图上显示不同程序之间的任何关系
  • 我们还可以使用计划指标绘制数据图,更多信息请参阅会议材料

使用事件图层创建地图{ #creating-a-map-using-the-event-layer }

  1. 在地图应用程序中,转到添加图层 -> 事件图层
  2. 您需要依次填写 5 个选项卡
  3. 数据选项卡:选择程序、程序阶段、坐标字段和事件状态
  4. 期间选项卡:选择您的期间
  5. 组织单位选项卡:选择您的组织单位
  6. 筛选选项卡:选择要从地图上筛选出的事件的标准。只有符合标准的事件才会显示在地图上
  7. 样式选项卡:样式选项卡上有几个选项会影响地图的输出效果
    1. 分组事件与查看所有事件
      1. 事件分组 :当您有许多事件时,将它们分组通常很有用。当您放大这些事件时,它们将开始分离成单个细节
      2. 查看所有事件:如果您正在处理数据的子集,您可能希望立即查看所有事件。如果您有很多事件并选择了该选项,那么地图放大后将无法使用。
    2. 颜色/半径:这将决定分组或单个事件的颜色/半径,如果它们没有应用样式的话
    3. 数据元素样式:这对于使用两种数据类型为我们的事件指定配色方案非常有用
      1. 包含选项集的数据项:将为选项集内的每个选项指定一种颜色
      2. 使用数字的数据项:将使用自动或预定义图例为其分配颜色
      3. 该选项将忽略您之前在 "颜色 "部分选择的任何颜色选项。
  8. 使用事件图层为地图添加边界层也是一个不错的选择,方法是进入添加图层 -> 边界,然后选择要为其添加边界的层或组。

使用 TEI 图层创建地图{ #create-a-map-using-the-tei-layer }

  1. 在地图应用程序中,转到添加图层 -> 跟踪实体
  2. 您需要依次填写 5 个选项卡
  3. 数据选项卡:选择跟踪的实体类型、计划和计划状态
  4. 关系 "选项卡:选中 "显示跟踪实体关系 "并选择关系类型
  5. 期间选项卡:选择期间类型以及开始和结束日期
  6. 组织单位选项卡:选择组织单位和选择模式
  7. 风格选项卡
    1. 选择跟踪实体的颜色和大小
    2. 选择相关实体的颜色和大小
    3. 选择用于连接被跟踪实体和相关实体的线条的颜色
  8. 使用事件图层为地图添加边界层也是一个不错的选择,方法是进入添加图层 -> 边界,然后选择要为其添加边界的层或组。

保存地图

  1. 进入文件菜单,选择 "保存 "选项
  2. 为地图命名并编写说明,然后选择 "保存"。

下载地图{ #download-a-map }

在应用程序中选择下载选项。这将打开一个新对话框。将图例放置在您想要的位置,然后选择 "下载 "下载地图。这将把地图的 PNG 文件下载到您的下载文件夹中。