Utilisation de l'application Line Listing¶
L'application Line Listing (Listage de lignes) est une nouvelle application qui remplace la fonctionnalité de listage de lignes de l'application Event Reports (Rapports d'événements), mais qui offre également de nouvelles fonctionnalités.
REMARQUE
Une compatibilité ascendante sera assurée avec l'application Rapports d'évènements, ce qui signifie que vous pouvez ouvrir les rapports d'événements existants relevant d'un type de liste de lignes dans l'application Liste de Lignes, mais que vous ne pouvez pas les sauvegarder sous le même nom dans l'application Liste de Lignes.
Créer et modifier une liste de ligne¶
Lorsque vous ouvrez l'application Line Listing dans le menu du DHIS2, une page blanche s'affiche et vous pouvez commencer à créer une liste de lignes.

Créer une liste de ligne¶
Liste de ligne¶
Dans l'application Line Listing, vous ne disposez actuellement que d'un seul type de sélection, qui est la Liste de lignes.

Entrée¶
(_ C'est similaire à ce que vous voyez dans l'application Rapports d'événements_). Lorsque vous ouvrez l'onglet Entrée, vous verrez ci-dessous deux options :
- Événement (voir les données individuelles d'un programme d'événements ou d'une étape de programme tracker)
- Inscription (voir les données de plusieurs étapes de programme tracker)

Dimensions du programme¶
(Dans l'application Rapports d'événements, celles-ci sont appelées dimensions des données).
La liste de lignes sera toujours basée sur les programmes d'événements ou tracker et vous pouvez effectuer une analyse sur une série de dimensions. Pour un programme contenant plusieurs catégories, vous pouvez utiliser les catégories de programme et les groupes d'options de catégorie comme dimensions.
Astuce
Dans l'application Line Listing, toutes les dimensions liées à un suivi ou à un programme d'événement sont présentes dans le composant de dimension du programme.
-
Choisir un programme
Sélectionnez le programme : Tous les programmes d'événements et de suivi seront visibles dans le menu déroulant.
Si vous avez sélectionné Évènement, pour les programmes tracker, vous devez sélectionner une étape de programme afin d'obtenir tous les éléments de données et attributs pour cette étape particulière. Pour pouvoir sélectionner des données provenant de plusieurs étapes, vous devez sélectionner "Inscription" comme type d'entrée.
Si vous sélectionnez un programme d'événement, vous n'avez pas besoin de sélectionner une étape (contrairement à l'application Rapports d'évènements).

Si vous sélectionnez Inscription dans l'onglet Entrée, tous les éléments de données associés au programme seront disponibles à différentes étapes du programme afin de permettre une sélection conjointe des éléments de données. Chaque élément de données servira de dimension.

Si vous voulez filtrer les données par éléments de données, attributs de programme, indicateurs de programme, catégorie, groupe d'options de catégorie, vous pouvez le faire en cliquant sur l'option de liste déroulante.

Il existe plusieurs façons d'ajouter des éléments de données à la présentation. Vous pouvez le faire en plaçant le curseur sur la dimension et en cliquant sur l'icône + ou par glisser-déposer directement dans la zone de présentation.

Vous pouvez également cliquer sur l'élément de données correspondant et choisir de l'ajouter à une colonne ou à un filtre, comme le montre la figure ci-dessous.

Chaque dimension peut comporter des critères (filtres). Les éléments de données de type ensemble d'options permettent de définir des critères "dans", où plusieurs options peuvent être sélectionnées.

Les valeurs numériques peuvent être comparées aux valeurs du filtre à l'aide des opérateurs "supérieur à", "égal à" ou "inférieur à". (Facultatif) Pour chaque élément de données, spécifiez un filtre à l'aide d'opérateurs tels que "supérieur à", "dans" ou "égal", ainsi qu'une valeur de filtre.
Remarque
L'amélioration de cette fonctionnalité est que vous pouvez ajouter plusieurs conditions et que différents opérateurs peuvent être utilisés. Vous pouvez également filtrer par vide ou non vide.

Dans l'application Line Listing pour les éléments de données de type BOOLEAN, l'analyse affichera " Oui ", " Non ", " Pas de réponse " au lieu de 0 et 1 comme dans l'application Event Reports ou l'application Data Visualizer.


La liste des lignes s'affiche sous la forme d'un tableau avec une ligne par événement. Chaque dimension peut être utilisée comme colonne dans le tableau ou comme filtre.

Votre dimension¶
Tous les ensembles de groupes de l'unité d'organisation sont présents dans le volet Votre dimension en vue d'une évaluation ou d'une analyse plus approfondie.
Dimensions principales et dimensions de programme¶
Sélectionner l'unité d'organisation¶
La boîte de dialogue de l'unité d'organisation est flexible et offre essentiellement trois possibilités de sélection des unités d'organisation :
- Sélection explicite : Utilisez l'arborescence pour sélectionner explicitement les unités d'organisation que vous souhaitez voir apparaître dans la visualisation. Lorsque vous faites un clic droit sur une unité d'organisation, vous pouvez alors facilement choisir de sélectionner toutes les unités d'organisation situées en dessous de celle-ci.
-
Niveaux et groupes : Les menus déroulants Niveau et Groupe sont un moyen pratique de sélectionner toutes les unités d'un ou plusieurs groupes d'unités d'organisation ou à des niveaux spécifiques. Exemple : sélectionnez CH Mahosot (niveau 3) pour obtenir toutes les unités de ce niveau.
NOTE
Please note that as soon as at least one level or group has been selected the org unit tree now acts as the boundary for the levels/groups. Example: if you select CH Mahosot (level 3) and Vientiane Capital org unit (at level 2) in the tree you get all units inside that district._
-
Les unités d'organisation de l'utilisateur :
- Unité d'organisation de l'utilisateur : Il s'agit d'un moyen de sélectionner dynamiquement les unités d'organisation auxquelles l'utilisateur connecté est associé.
- Sous-unités de l'utilisateur : Sélectionne les sous-unités de l'unité d'organisation de l'utilisateur.
- Sous-unités utilisateur x2 : Sélectionne les unités à deux niveaux en dessous de l'unité d'organisation des utilisateurs.

Statut de l'événement¶
Filtre les données en fonction de l'état de l'événement : Actif, Terminé, Programmé.
Vous pouvez visualiser les données concernant un statut d'événement particulier

Statut du programme¶
Filtre les données en fonction du statut du programme : Actif, Terminé ou Annulé.

Créer par/ Dernière mise à jour par¶
Affiche les données en fonction du créateur de l'événement en question.
Dimensions du temps¶
Cette nouvelle fonctionnalité de l'application Line Listing vous permettra de visualiser les données sur la base de différentes dimensions temporelles.
- Date de l'événement/Date de rédaction du rapport
- Date à laquelle le patient a été enregistré dans le système de santé.
- Date de l’incident
- Dernière mise à jour le
- Date de programmation
Vous pouvez cliquer sur la dimension temporelle ci-dessus pour visualiser les données sur différentes périodes. Une fenêtre s'ouvre et vous permet de sélectionner une ou plusieurs périodes.
Vous disposez de trois options de période : périodes relatives, périodes fixes et dates de début/fin. Vous pouvez combiner des périodes fixes et des périodes relatives dans le même tableau. Vous ne pouvez pas combiner des périodes fixes et des périodes relatives avec des dates de début/fin dans le même tableau. Les périodes qui se chevauchent sont filtrées de manière à ne paraître qu'une seule fois.
- Les périodes fixes : Dans la case Sélectionner le type de période, sélectionnez un type de période. Vous pouvez sélectionner un nombre quelconque de périodes fixes dans n'importe quel type de période. Les périodes fixes peuvent par exemple être "janvier 2021".
- Les périodes relatives : Dans la partie inférieure de la section Périodes, sélectionnez autant de périodes relatives que vous le souhaitez. Les noms sont relatifs à la date actuelle. Cela signifie que si le mois en cours est mars et que vous sélectionnez Dernier mois, le mois de février est inclus dans la visualisation. Les périodes relatives présentent l'avantage de maintenir les données du rapport à jour au fil du temps.
- Dates de début/fin : Sélectionner Dates de début/fin près de Choisir les préréglages du formulaire. Ce type de période vous permet de spécifier des dates flexibles pour la fourchette de temps du rapport.

Entête de colonne¶
Vous pouvez effectuer un tri de tous les entêtes de colonnes
Vous pouvez filtrer la colonne concernée en cliquant directement sur les éléments de données ou les attributs de la colonne et vous serez en mesure d'effectuer un tri des valeurs de données.
Exemple
Dans la capture d'écran ci-dessous, nous avons sélectionné AEFI - Headache.
Une fois que nous avons cliqué sur AEFI - Headache, nous obtenons une boîte de dialogue dans laquelle nous devons sélectionner l'option que nous voulons filtrer. Dans ce cas, nous avons sélectionné "Oui" uniquement.
{largeur=50% }
Une fois que nous aurons cliqué sur mettre à jour nous obtiendrons la liste des lignes avec seulement "Oui" sous AEFI - Headache.
Événements répétitifs¶
Il s'agit d'une nouvelle fonctionnalité de l'application Liste de lignes.
Si l'étape du programme comporte un élément de données dans un événement répétitif, vous pouvez cliquer sur l'élément de données et la fenêtre s'ouvrira et vous pourrez voir l'onglet Événement répétitif.

Vous pouvez ensuite définir les événements les plus récents et les plus anciens que vous souhaitez voir apparaître dans le résultat, comme indiqué ci-dessous.

Une fois que vous aurez cliqué sur mettre à jour, vous pourrez visualiser les événements de cette étape du programme répétitif, comme indiqué ci-dessous.

Application des couleurs à la légende¶
Vous pouvez appliquer des couleurs à une visualisation en utilisant la fonction de légende, qui se trouve en dessous de Options -> Légende

| Option | Description |
|---|---|
| Utiliser une légende pour les couleurs des cellules d'un tableau | Ajouter une légende aux éléments de visualisation, qui est une couleur basée sur une valeur pour chaque élément. Les légendes elles-mêmes sont configurées dans l'application Maintenance. |
| style de la légende | Contrôle l'endroit où la couleur de la légende est appliquée, soit au texte, soit à l'arrière-plan. Vous pouvez utiliser cette option pour les tableaux de bord afin d'identifier les valeurs élevées et faibles en un clin d'œil. |
| Type de légende | Contrôle du type de légende attribuée. Utiliser une légende prédéfinie par élément de données attribue une légende à chaque élément de données ou indicateur concerné, en fonction de la légende attribuée à chacun d'eux dans l'application Maintenance. Sélectionner une légende unique pour l'ensemble de la visualisation attribue une légende unique à tous les éléments de données, choisis dans une liste déroulante de légendes disponibles. |
| Afficher la clé de la légende | Affiche une clé pour la légende sur le côté droit de la visualisation, afin d'indiquer les séries de valeurs et leur couleur respective. |
Vous trouverez ci-dessous un exemple de liste de lignes avec des couleurs de légende appliquées à l'arrière-plan, par élément de données.

Afficher la hiérarchie des unités d'organisation¶
Vous pouvez afficher le chemin hiérarchique complet des unités d'organisation en activant l'option Afficher la hiérarchie des unités d'organisation dans Options -> Style. Lorsque cette option est activée, le tri dans la colonne des unités d'organisation se fera par ordre alphabétique en commençant par le niveau supérieur.

Sauter l'arrondi pour les valeurs numériques¶
Vous pouvez contrôler la façon dont les valeurs numériques sont formatées en activant l'option Ignorer l'arrondi dans Options -> Données. Lorsque cette option est activée, les valeurs numériques ne sont pas arrondies et toutes les décimales sont affichées. Par défaut, l'arrondi est appliqué.
Vous trouverez ci-dessous un exemple du même tableau avec et sans l'option appliquée.

Afficher les options¶
Pour libérer de l'espace pour la liste des lignes elle-même, il existe plusieurs façons de masquer les panneaux en haut et sur les côtés :
- Le bouton "plein écran" dans la barre de titre masque la barre latérale principale à gauche et le panneau de configuration en haut de l'écran.
- Si le panneau des interprétations est déroulé sur la droite, il peut être masqué en cliquant sur le "bouton interprétations" juste en dessous du menu profil de l'utilisateur.
- Chaque panneau peut également être affiché/masqué en utilisant le "menu Affichage" dans la barre d'outils principale.

Pour donner plus d'espace au contenu du "panneau latéral des accessoires", celui-ci peut être redimensionné à l'aide de la souris, comme illustré ci-dessous :

Le redimensionnement peut également être effectué à l'aide des touches de direction gauche/droite du clavier. Ces raccourcis clavier sont activés après que la priorité soit donnée à la poignée de redimensionnement (en appuyant plusieurs fois sur la touche de tabulation) :

Le "panneau latéral des accessoires" peut être ramené à sa largeur par défaut en utilisant le menu "Affichage" ou en double-cliquant sur la poignée de redimensionnement.

{largeur=50% }