Aller au contenu
For the complete DHIS2 documentation index, see llms.txt.

Utiliser l'application Visualiseur de données

Création et édition de visualisations

Lorsque vous ouvrez l'application data-visualizer (Visualiseur de données) à partir du menu dhis2, vous obtenez une ardoise vierge et vous pouvez commencer à créer votre visualisation immédiatement.

Sélectionnez un type de visualisation

Sélectionnez le type de visualisation souhaité à l'aide du sélecteur situé dans le coin supérieur gauche. Pour chaque type de visualisation, vous trouverez une brève description avec des suggestions sur l'utilisation des principales dimensions dans la mise en page.

Type de visualisation Description
Colonne Affiche les informations sous forme de colonnes rectangulaires verticales dont la longueur est proportionnelle aux valeurs qui y sont contenues.

Par exemple : la comparaison des performances de différents districts.

Restrictions relatives à la mise en page : 1 seule dimension comme série, 1 seule dimension comme catégorie.
Colonnes empilées Affiche les informations sous forme de colonnes rectangulaires verticales, où des barres représentant plusieurs catégories sont empilées les unes par-dessus les autres.

Par exemple : affichage des tendances ou des sommes d'éléments de données connexes.

Restrictions relatives à la mise en page : identiques à celles de la Colonne.
Barre Identique aux colonnes, mais avec des barres horizontales.
Barres empilées Identique aux colonnes empilées, mais avec des barres horizontales.
Ligne Affiche les informations sous la forme d'une série de points reliés par des lignes droites. Également appelée série chronologique.

Exemple : visualisation des tendances des données des indicateurs sur des intervalles de temps.

Restrictions relatives à la mise en page : identiques à celles de la Colonne.
Zone Elle repose sur une ligne (ci-dessus), l'espace entre l'axe et la ligne étant rempli de couleurs et les lignes étant empilées les unes par-dessus les autres.

Par exemple : comparaison des tendances des indicateurs connexes.

Restrictions relatives à la mise en page : identiques à celles de la Colonne.
Zones empilées Similaire à Zone, mais les zones des différents éléments de dimension sont empilées les unes par-dessus les autres.

Par exemple : comparaison des tendances des indicateurs connexes.

Restrictions relatives à la mise en page : identiques à celles de la Zone.
Secteur Cercle divisé en secteurs (ou sections).

Exemple : visualisation de la proportion de données pour des éléments de données individuels par rapport à la somme totale de tous les éléments de données.

Restrictions relatives à la mise en page : 1 seule dimension comme série, sans catégorie.
Radar Affiche les données sur les axes à partir du même point. Il est également connu sous le nom de diagramme en araignée.

Restrictions de mise en page : les mêmes que pour la Colonne.
Jauge Demi-cercle affichant une seule valeur, généralement sur 100% (les valeurs de début et de fin sont configurables).

Restrictions relatives à la mise en page : 1 seule dimension avec 1 seul élément comme série, la dimension des données est verrouillée sur la série.
D'année en année (ligne) Utile lorsque vous souhaitez comparer une année de données à d'autres années de données sur la base des années civiles.

Restrictions relatives à la mise en page : la dimension Période est désactivée.
D'année en année (colonne) Identique à l'option Année après année (ligne), uniquement avec des colonnes.
Valeur unique Affiche une valeur unique d'une manière adaptée au tableau de bord. Si la dimension affichée est associée à un type d'indicateur, un symbole % ou une chaîne ( par mille, par cent mille, etc...) est ajouté à la valeur.
Si une icône est associée à la dimension dans l'application Maintenance, elle peut être affichée parallèlement à la valeur, l'icône peut être modifiée dans le panneau Options.

Restrictions de mise en page : les mêmes que pour la Jauge.
Tableau croisé dynamique Résume les données d'un tableau plus détaillé et pourrait reprendre des sommes, des moyennes ou d'autres statistiques regroupées de manière significative par le tableau croisé dynamique.

Restrictions relatives de mise en page : aucune.
Diffusion Les diagrammes de diffusion permettent aux utilisateurs de représenter les unités organisationnelles sous forme de tableaux en fonction de deux variables pour une seule période fixe ou relative.

Les restrictions de mise en page : 1 seul élément vertical et horizontal, la dimension des données est verrouillée à la verticale et à l'horizontale, l'unité organisationnelle est verrouillée en fonction des tableaux.
Tableau des valeurs atypiques Affiche une liste de valeurs atypiques basées sur des données historiques.

Restrictions de mise en page : les dimensions unité d'organisation, période et données sont verrouillées sur les colonnes, aucune autre dimension ne peut être ajoutée.

Sélectionner les dimensions

Dans le menu de dimension sur la gauche, vous pouvez sélectionner la dimension que vous voulez afficher dans votre visualisation, y compris les données, la période, les unités d'organisation et les dimensions dynamiques. Vous pouvez l'ajouter en cliquant sur une dimension, en glissant et déposant une dimension dans la zone de mise en page ou en survolant une dimension et en utilisant son menu contextuel (trois points).

Tout comme dans le menu des dimensions, dans la zone de mise en page, vous pouvez également modifier les sélections en cliquant sur une dimension, en glissant et déposant une dimension ou en utilisant le menu contextuel d'une dimension (trois points).

  • Séries : Une série est un ensemble d'éléments continus et liés (par exemple des périodes ou des éléments de données) que vous souhaitez visualiser afin de mettre en évidence des tendances ou des relations dans ses données. Également connues sous le nom de Colonnes pour les visualisations de Tableaux croisés dynamiques
  • Catégories : Une catégorie est un ensemble d'éléments (par exemple des indicateurs ou unités d'organisation) pour lesquelles vous souhaitez comparer les données. On les appelle également Rangées pour les visualisations de Tableaux croisés dynamiques.
  • Filtre : La sélection du filtre permet de filtrer les données affichées dans la visualisation. Notez que si vous utilisez la dimension des données comme filtre, vous ne pouvez spécifier qu'un seul indicateur ou ensemble de données comme élément de filtre, alors qu'avec d'autres types de dimensions, vous pouvez sélectionner un nombre quelconque d'éléments.

Sélectionner les éléments de dimension

Une dimension renvoie aux éléments décrivant les valeurs de données dans le système. Il existe trois dimensions principales dans le système :

  • Data: Includes data elements, indicators, datasets (reporting rates), event data items, program indicators and calculations, describing the phenomena or event of the data.

    NOTE: Clarification of display of reporting rates:

    1. If a report is expected but not yet submitted, then "0" will be displayed.
    2. If a report is not expected because the metadata (e.g. category option, OU) date is outside of the start-end date range, then no value is displayed. (e.g. "blank")
  • Périodes : Indique quand l'événement a eu lieu.
  • Unités d'organisation : Décrit où l'événement a eu lieu.

L'application Visualiseur de données est très flexible puisqu'il vous permet d'utiliser ces dimensions comme séries, catégories et filtres.

Pour sélectionner les éléments d'une dimension, ouvrez la fenêtre modale de la dimension en cliquant sur une dimension. Cette fenêtre s'ouvre également automatiquement lorsque vous ajoutez une dimension sans éléments sélectionnés dans la mise en page. Sélectionnez les éléments à ajouter à la visualisation en double-cliquant sur un élément ou en sélectionnant un élément en un seul clic et en utilisant les flèches au milieu. L'ordre d'apparition sera le même que l'ordre dans lequel ils sont sélectionnés. Les éléments sélectionnés peuvent alors être réorganisés par simple glisser-déposer dans la section Sélectionnés.

Sélectionner des éléments de données

When selecting data items, there are different ways to filter the displayed items. By using the search field at the top, a global search by item name, id or code is performed across the currently selected Data Type. By selecting a Data Type from the dropdown, items can be filtered by type and subtype, where the subtype available depends on the selected data type. The name search and the type/subtype filtering can be combined as well for a more detailed filter. The type of each displayed item is indicated on the right and a corresponding icon is shown on the left of the item.

Sélectionner des options dans un ensemble d'options

Pour les éléments de données auxquels un ensemble d'options a été attribué, il est possible de sélectionner des options spécifiques de l'ensemble d'options. Pour ces éléments de données, une icône est affichée à côté du nom de l'élément de données.

En cliquant dessus, la liste des éléments de données est remplacée par la liste des options de l'ensemble d'options. La sélection des options se fait de la même manière que pour tout autre élément de données, en double-cliquant ou en utilisant les boutons de transfert. Pour quitter le mode options, utilisez le bouton "Retour vers tous les éléments".

Afficher des informations sur un élément de données

À droite de chaque élément de données se trouve une icône d'information. Cliquez dessus pour afficher un tableau avec des informations pertinentes. Les informations affichées dépendent du type de données de l'élément.

Utiliser des calculs personnalisés

Un nouvel indicateur personnel, également appelé calcul personnalisé, peut être créé en cliquant sur le bouton + Calcul en bas à gauche de la fenêtre modale Données. La fenêtre modale Calcul s'ouvre alors.

Les calculs personnalisés précédemment créés peuvent être trouvés dans la liste des dimensions de la fenêtre modale Données, soit en faisant défiler, soit en recherchant, soit en utilisant le filtre Calculs du Type de données. Pour éditer un calcul personnalisé, cliquez sur le bouton d'édition (indiqué par une icône en forme de stylo) sur l'élément lui-même.

La fenêtre modale Calcul dispose de filtres d'éléments de données similaires à ceux de la fenêtre modale Données, où les éléments peuvent être trouvés par défilement, recherche ou filtrage par groupes. Pour ajouter un élément de données ou un opérateur mathématique au champ de formule (à droite), double-cliquez sur l'élément ou faites-le glisser dans le champ de formule.

Items in the formula field can be rearranged by drag-and-drop and removed by either double-click or by selecting an item and clicking the Remove item button.

Tous les calculs doivent être nommés avant d'être enregistrés.

La formule sera validée lors de l'enregistrement. Notez que seules les formules valides peuvent être sauvegardées. La formule peut également être validée sur demande en cliquant sur le bouton Vérifier la formule.

Sélectionner les périodes

Lors de la sélection d'une Période, vous avez la possibilité de choisir entre des périodes fixes et des périodes relatives. Celles-ci peuvent également être combinées. Les périodes qui se chevauchent sont filtrées de manière à ne figurer qu'une seule fois. Pour les périodes relatives, les noms sont relatifs à la date actuelle. Par exemple, si le mois en cours est mars et que Mois dernier est sélectionné, le mois de février est affiché dans la visualisation.

Sélectionnez les unités d'organisation

La boîte de dialogue des unités d'organisation est flexible et propose essentiellement trois façons de sélectionner les unités d'organisation :

  • Sélection explicite : Utilisez l'arbre pour sélectionner explicitement les unités d'organisation que vous souhaitez voir apparaître dans la visualisation. Lorsque vous faites un clic droit sur une unité d'organisation, vous pouvez alors facilement choisir de sélectionner toutes les unités d'organisation situées en dessous de celle-ci.

  • Niveaux et groupes : Les menus déroulants Niveau et Groupe permettent de sélectionner facilement toutes les unités d'un ou de plusieurs groupes d'unités d'organisation ou à des niveaux spécifiques. Exemple : sélectionnez Chefferie (niveau 3) pour obtenir toutes les unités d'organisation de ce niveau.

    Veuillez noter que dès que vous avez sélectionné au moins un niveau ou un groupe, la hiérarchie des unités organisationnelles fait office de limite pour les niveaux/groupes. Par exemple : si vous sélectionnez Chefferie (niveau 3) et Kailahun unité d'organisation (au niveau 2) dans la hiérarchie, vous obtenez toutes les unités de chefferie du district de Kailahun.

  • Les unités d'organisation de l'utilisateur :

    • Unité d'organisation des utilisateurs : Il s'agit d'un moyen de sélectionner de façon dynamique les unités d'organisation auxquelles l'utilisateur connecté est associé.

    • Sous-unités d'utilisateurs : Sélectionne les sous-unités de l'unité d'organisation des utilisateurs.

    • Sous-unités utilisateur x2 : Sélectionne les unités à deux niveaux en dessous de l'unité d'organisation des utilisateurs.

Sélectionner les dimensions dynamiques

Lors de la sélection d'une dimension dynamique, il est possible de sélectionner des éléments uniques ou l'ensemble des éléments. L'option par défaut Sélectionner manuellement les éléments est sélectionnée , ce qui permet de choisir des éléments uniques dans une liste, aussi bien que les champs Données et Période sélectionnés ci-dessus. Pour sélectionner automatiquement tous les éléments d'une dimension, l'option Inclure automatiquement tous les éléments peut être sélectionnée. Cette option couvre également tous les éléments supplémentaires qui seront ajoutés à l'avenir si les éléments de dimension disponibles sont mis à jour.

Graphiques à deux catégories

Most chart visualization types can show two categories. When switching from Pivot Table to Column, Bar, Area (and their stacked versions), or Line charts, the first two dimensions remain in Category while any additional dimensions are moved to Filter. The labels for the first dimension in Category are shown at the top of the chart, and the ones for the second dimension at the bottom. The resulting visualization is composed of separate charts, one for each item in the first dimension.

Modifier l'affichage de votre visualisation

Vous pouvez modifier l'affichage d'une visualisation en activant/désactivant et en configurant plusieurs options. Chaque type de visualisation peut disposer d'un ensemble différent d'options. Les options sont organisées en onglets dans la Boîte de dialogue des options et en sections à l'intérieur de chaque onglet.

  1. Cliquez sur Options pour ouvrir la Boîte de dialogue des options.

  2. Parcourez les onglets de la boîte de dialogue pour accéder aux options disponibles.

  3. Configurez les options souhaitées selon vos besoins.

  4. Cliquez sur Mettre à jour pour appliquer les modifications apportées à la visualisation.

Liste des options disponibles

Option Description
Data tab — Charts
Les valeurs empilées totalisent 100% Affiche des valeurs empilées à 100 % dans les visualisations de colonnes empilées et de barres empilées.
Valeurs cumulées Displays cumulative values in the visualization. Not available for Gauge, Pie, Single value, Scatter and Outlier table.
Masquer les catégories vides Masque les éléments de catégorie sans données provenant de la visualisation.
Avant la première : masque les valeurs manquantes uniquement avant la première valeur
Après la dernière : masque les valeurs manquantes uniquement après la dernière valeur
Avant la première et après la dernière : masque les valeurs manquantes uniquement avant la première valeur et après la dernière valeur
Tout : masque toutes les valeurs manquantes
TCeci s'avère utile, par exemple, lorsque vous créez des visualisations de colonnes et de barres.
Ordre de tri personnalisé Contrôle l'ordre de tri des valeurs.
Ignorer les arrondis Ignore les arrondis des valeurs des données, ce qui permet d'obtenir une précision totale des valeurs des données. Cela peut être utile pour les données financières lorsque le montant total en dollars est requis.
Ligne de tendance Affiche la ligne de tendance permettant de visualiser l'évolution de vos données dans le temps. Elle indique, par exemple, si les performances s'améliorent ou se détériorent. Elle est utile lorsque l'on choisit des périodes comme catégorie.
Ligne cible Affiche une ligne horizontale à la valeur de domaine concernée. Elle est utile, par exemple, lorsque vous souhaitez comparer vos performances à l'objectif actuel.
Ligne de base Affiche une ligne horizontale à la valeur de domaine concernée. Elle est utile, par exemple, lorsque vous souhaitez afficher l'évolution de vos performances depuis le début d'un processus.
Type d'agrégation Permet de définir comment les éléments de données ou les indicateurs seront agrégés dans la visualisation. Certains des types d'agrégation sont Par élément de donnée, Nombre, Min et Max.
Inclure uniquement les événements achevés Inclut uniquement les événements achevés dans le processus d'agrégation. Ceci est utile par exemple pour exclure des événements non finalisés dans le calcul des indicateurs.
Max results (Outlier table only) Sets the maximum number of rows to display in an Outlier table. The allowed range is 1 to 500.
Data tab — Pivot table
Valeurs cumulées Displays cumulative values in the Pivot table.
Étiquettes des dimensions Shows the names of dimensions (e.g., Data, Period, Organisation unit) as column and row headers in the Pivot table.
Ignorer les arrondis Ignore les arrondis des valeurs des données, ce qui permet d'obtenir une précision totale des valeurs des données. Cela peut être utile pour les données financières lorsque le montant total en dollars est requis.
Totaux des colonnes Affiche les valeurs totales dans un tableau croisé dynamique pour chaque colonne, ainsi qu'un total pour toutes les valeurs du tableau.
Sous-totaux des colonnes Affiche les sous-totaux dans un tableau croisé dynamique pour chaque dimension.
Si vous ne sélectionnez qu'une seule dimension, les sous-totaux seront masqués pour ces colonnes. Ceci est dû au fait que les valeurs seront égales aux sous-totaux.
Totaux des rangées Affiche les valeurs totales dans un Tableau croisé dynamique pour chaque rangée, ainsi qu'un total pour toutes les valeurs du tableau.
Sous-totaux des rangées Affiche les sous-totaux dans un tableau croisé dynamique pour chaque dimension.
Si vous ne sélectionnez qu'une seule dimension, les sous-totaux seront masqués pour ces rangées. Ceci est dû au fait que les valeurs seront égales aux sous-totaux.
Masquez les colonnes vides Masque les colonnes vides d'un tableau croisé dynamique. Ceci est utile lorsque vous consultez de grands tableaux dans lesquels une grande partie des éléments de dimension ne dispose pas de données, ceci afin de préserver la lisibilité du le tableau.
Masquez les lignes vides Masque les rangées vides d'un tableau croisé dynamique. Ceci est utile lorsque vous regardez de grands tableaux dans lesquels une grande partie des éléments de dimension ne dispose pas de données, ceci afin de préserver la lisibilité du tableau.
Type d'agrégation Permet de définir comment les éléments de données ou les indicateurs seront agrégés dans la visualisation. Certains des types d'agrégation sont Par élément de donnée, Nombre, Min et Max.
Type de nombre Définit le type de valeur que vous souhaitez afficher dans un tableau croisé dynamique : Valeur, Pourcentage de la ligne ou Pourcentage de la colonne.
Les options Pourcentage de la ligne et Pourcentage de la colonne impliquent la visualisation des valeurs en pourcentage du total de la ligne ou en pourcentage du total de la colonne au lieu de la valeur agrégée. Cette option est utile lorsque vous souhaitez voir la contribution des éléments de données, des catégories ou des unités d'organisation à la valeur totale.
Inclure uniquement les événements achevés Inclut uniquement les événements achevés dans le processus d'agrégation. Ceci est utile par exemple pour exclure des événements non finalisés dans le calcul des indicateurs.
Onglet Légende
Utiliser une légende pour les couleurs du graphique Ajoute une légende aux éléments de visualisation, qui est une couleur basée sur une valeur pour chaque élément. Les légendes elles-mêmes sont configurées dans l'application Maintenance.
Legend style (Pivot table and Single value only) Contrôle l'endroit où la couleur de la légende est appliquée, soit au texte, soit à l'arrière-plan. Vous pouvez utiliser cette option pour les tableaux de bord afin d'identifier les valeurs élevées et faibles en un clin d'œil.
Type de légende Contrôle du type de légende attribuée.
Utiliser une légende prédéfinie par élément de données attribue une légende à chaque élément de données ou indicateur concerné, en fonction de la légende attribuée à chacun d'eux dans l'application Maintenance.
Sélectionner une légende unique pour l'ensemble de la visualisation attribue une légende unique à tous les éléments de données, choisis dans la barre de menu déroulante des légendes disponibles.
Afficher la clé de la légende Affiche une référence pour la légende sur le côté droit de la visualisation, afin d'indiquer les échelles de valeurs et leurs couleurs respectives. Si la visualisation est ajoutée à un tableau de bord, cette option peut également être activée dans le coin supérieur droit du tableau de bord.
Onglet des axes
Titre des axes Saisissez un titre ici pour afficher une légende à côté de l'axe des x ou des y. Utile lorsque vous souhaitez donner des informations contextuelles à la visualisation, par exemple sur l'unité de mesure.
Auto generated from axis items fournit un titre basé sur le contenu de l'axe.
None supprime le titre.
Custom vous permet de saisir un titre personnalisé.
Axe de la plage Définit la valeur maximale et minimale à afficher sur l'axe de la plage.
Étapes Définit le nombre de tiques qui seront visibles sur l'axe de la plage.
Décimales Définit le nombre de décimales à utiliser pour les valeurs de l'axe des plages.
Étiquettes Controls the text styling of the value labels shown on each axis. Font size, color and italic/bold variants can be customized.
Onglet Séries
Cet onglet permet d'ajouter des axes supplémentaires et de modifier l'affichage des différentes séries. Veuillez consulter la description détaillée de cette opération dans les sections correspondantes ci-dessous.
Style tab — Charts
Étiquettes de valeur Affiche les valeurs supérieures à la série dans la visualisation.
Aucun espace entre les barres/colonnes Supprime l'espace entre les colonnes ou les barres dans la visualisation. Cette option est utile pour afficher la visualisation sous forme de courbe EPI.
Show series key Shows a key for the series in the visualization, identifying each data series by color and name. The series key appearance can be customized using the text styling tool.
Digit group separator (Single value only) Permet de contrôler le caractère à utiliser dans la séparation de groupes de chiffres ou de "milliers". Vous pouvez le définir sur Virgule, Espace ou Aucun.
Show data item icon (Single value only) Permet de faire basculer la visibilité de l'icône dans la visualisation d'une Valeur Unique.
Chart title Contrôle le titre qui apparaît au-dessus de la visualisation.
La fonction Auto generated utilise le titre par défaut généré à partir des dimensions/filtres de la visualisation.
Aucune suppression du titre.
La fonction Custom vous permet de saisir un titre personnalisé.
Chart subtitle Contrôle le sous-titre qui apparaît au-dessus de la visualisation.
La commande Auto generated utilise le sous-titre par défaut généré à partir des dimensions/filtres de la visualisation.
Aucune suppression du sous-titre.
La commande Custom permet de saisir un sous-titre personnalisé.
Jeu de couleurs Contrôle les couleurs utilisées dans les graphiques. Une liste des jeux de couleurs disponibles s'affiche avec un aperçu des couleurs. Il existe également une option "Motifs mono" qui utilise des motifs colorés au lieu de couleurs pleines.
Style tab — Pivot table
Display density, Font size, Digit group separator and Display organisation unit hierarchy also apply to the Outlier table.
Table title Contrôle le titre qui apparaît au-dessus de la visualisation.
La fonction Auto generated utilise le titre par défaut généré à partir des dimensions/filtres de la visualisation.
Aucune suppression du titre.
La fonction Custom vous permet de saisir un titre personnalisé.
Table subtitle Contrôle le sous-titre qui apparaît au-dessus de la visualisation.
La commande Auto generated utilise le sous-titre par défaut généré à partir des dimensions/filtres de la visualisation.
Aucune suppression du sous-titre.
La commande Custom permet de saisir un sous-titre personnalisé.
Densité d'affichage Permet de contrôler la taille des cellules dans un tableau croisé dynamique. Vous pouvez le définir sur Confortable, Normal ou Compact.
Le mode compact est utile lorsque vous voulez adapter de grands tableaux à l'écran du navigateur.
Taille de la police Contrôle la taille de la police de texte d'un tableau croisé dynamique. Vous pouvez la définir sur Grande, Normale ou Petite.
Séparateur de groupes de chiffres Permet de contrôler le caractère à utiliser dans la séparation de groupes de chiffres ou de "milliers". Vous pouvez le définir sur Virgule, Espace ou Aucun.
Ajuster les en-têtes de colonnes en haut du tableau Gel des en-têtes de colonne dans les tableaux croisés dynamiques afin qu'ils soient toujours visibles lors du défilement du contenu du tableau.
Ajuster les en-têtes de ligne à gauche du tableau Verrouille les en-têtes de ligne dans les tableaux croisés dynamiques afin qu'ils soient toujours visibles lorsque l'on fait défiler le contenu du tableau.
Afficher la hiérarchie des unités d'organisation Affiche le nom de tous les ascendants des unités d'organisation, par exemple "Sierra Leone / Bombali / Tamabaka / CPS Sanya" pour le "CPS Sanya".
Les unités d'organisation sont ensuite triées par ordre alphabétique, ce qui permet de les classer selon la hiérarchie.
Lorsque vous téléchargez un tableau croisé dynamique ayant des unités d'organisation comme lignes et que vous avez sélectionné Afficher la hiérarchie des unités d'organisation, chaque niveau d'unité d'organisation est rendu sous la forme d'une colonne séparée. Cette opération est utile, par exemple, lorsque vous créez des tableaux croisés dynamiques Excel sur un ordinateur local.
Onglet Valeurs limites
Valeurs limites minimales/maximales Permet de filtrer les données côté serveur.
Vous pouvez configurer le système de manière à ne renvoyer que les enregistrements dont la valeur des données agrégées est égale, supérieure, supérieure ou égale, inférieure ou inférieure ou égale à une valeur donnée.
Lorsque les deux parties du filtre sont utilisées, il est alors possible de filtrer une série d'enregistrements de données.
Parameters tab (Pivot table only)
These settings control how the pivot table behaves when embedded as a standard report in the Reports app. They have no effect within Data Visualizer itself.
Période de déclaration Controls whether the user is prompted to enter a report period when creating a standard report in the Reports app.
Unité d’organisation Controls whether the user is prompted to enter an organisation unit when creating a standard report in the Reports app.
Unité d'organisation mère Controls whether the user is prompted to enter a parent organisation unit when creating a standard report in the Reports app.
Inclure les valeurs obtenues par régression Includes a column with regression values in the Pivot table.
Inclure les valeurs cumulées Includes a column with cumulative values in the Pivot table.
Ordre de tri personnalisé Contrôle l'ordre de tri des valeurs.
Limite maximale Permet de contrôler le nombre maximum de lignes à inclure dans un tableau croisé dynamique.
Outliers tab (Scatter chart and Outlier table only)
Outlier analysis (Scatter) Enables outlier detection in a Scatter chart, highlighting data points that are markedly different from the rest of the data. When enabled, the outlier detection method and extreme lines options become available.
Outlier detection method (Scatter and Outlier table) Outlier analysis is a process that involves identifying anomalous observations in a dataset. In Data Visualizer outliers are detected by first normalizing the data into a linear regression line and then analysing each point's distance from regression line. For Scatter charts, three methods are supported: Interquartile Range (IQR) is based on dividing a dataset into quartiles; Modified z-score is based on the Median Absolute Deviation (MAD). IQR and MAD are considered the two most common robust measures of scale. Standard z-score is based on standard deviation and is therefore considered less robust as it is greatly influenced by outliers. For Outlier table, Modified z-score and Standard z-score are supported.
Threshold factor (Scatter and Outlier table) Le chiffre par lequel les seuils de valeurs aberrantes sont multipliés. Contrôle la sensibilité de I'échelle des seuils. Les facteurs par défaut sont 1,5 pour l'IQR et 3 pour les z-scores.
Extreme lines (Scatter) Marks data points at the extreme ends of the distribution as lines on the Scatter chart. Calculated as a percentage of the total values along an axis. Only available when Outlier analysis is enabled.
Extreme line % detection (Scatter) The percentage threshold used to calculate which values are shown as extreme lines. Default is 1%.

Style personnalisé du texte et de la clé de série dans les graphiques{ #custom-styling-for-text-and-series-key-in-charts }

Vous pouvez personnaliser les options suivantes à l'aide de l'outil de mise en forme de texte : Titre du graphique, Sous-titre du graphique, Clé de la légende, Ligne cible, Ligne de base, Titre de l'axe et Étiquettes pour les axes horizontal et vertical. L'outil de mise en forme de texte permet de choisir une taille de police, une couleur et des variantes en italique/gras. Il est également possible de choisir la position du texte.

Ajout de catégories attribuées

Les Catégories attibuées sont une dimension composite représentant les combinaisons d'options de catégories associées à la combinaison de catégories de l'élément de données sélectionné. Cette dimension peut être ajoutée en faisant glisser la dimension Catégories attibuées du menu de dimensions à gauche dans la disposition de visualisation :

Une autre façon d'ajouter des catégories attribuées consiste à accéder à l'option Ajouter des catégories attribuées dans le menu contextuel de la dimension Données (non disponible pour Jauge, Année après année ou Valeur unique).

Ajouter d'autres axes

En combinant des données avec différentes échelles de mesure, vous obtiendrez une visualisation plus significative en ayant plus qu'un seul axe. Pour les graphique à Colonnes, barres et lignes, et en Zone vous pouvez cliquer sur Gérer les axes du graphique dans le menu contextuel de la dimension Données. Si l'option est désactivée, assurez-vous que la dimension Données se trouve sur l'axe Série et qu'au moins deux éléments y ont été ajoutés.

On dispose de quatre axes, deux sur le côté gauche (axes 1 et 3) du tableau et deux sur le côté droit (axes 2 et 4). Chaque axe a une couleur différente et les éléments du graphique seront colorés en conséquence.

Remarque

Lorsque plusieurs axes sont utilisés, l'option jeu de couleurs de l'onglet Style est désactivée. Les options Ligne cible et Ligne de base sont disponibles dans l'onglet Axes pour chaque pôle.

Utilisation de plusieurs types de visualisation

Il est possible de combiner un diagramme à Colonnes avec des éléments à Lignes et vice versa. Cela se fait en cliquant sur l'onglet Séries dans la fenêtre de dialogue Options et en changeant le Type de visualisation. Il est également possible de combiner ces éléments en utilisant plusieurs axes (tel que décrit dans la section ci-dessus).

Il en résulte un graphique qui combine les types Colonne et Ligne.

Exploration de données

Cette fonctionnalité est activée pour les types de visualisation Tableau croisé, Colonne, Colonne empilée, Barre et Barre empilée et permet de faire des recherches dans les données en cliquant sur une valeur de cellule / colonne / barre dans la visualisation. Un menu contextuel s'ouvre avec différentes options.

Il est possible d'explorer les données par unité d'organisation, c'est-à-dire en naviguant vers le haut et vers le bas de la structure hiérarchique de l'unité d'organisation. La recherche de données affecte la sélection de dimension actuelle dans la zone de mise en page. La dimension de l'unité d'organisation doit donc être présente sur l'axe Colonnes / Séries ou sur l'axe Lignes / Catégories pour que la fonction d'exploration soit activée.

Exploration des données dans un tableau croisé dynamique

Exploration des données dans un graphique à colonnes

Gérer les visualisations sauvegardées

La sauvegarde de vos visualisations permet de les retrouver facilement par la suite. Vous pouvez également choisir de les partager avec d'autres utilisateurs ou de les afficher sur un tableau de bord.

Ouvrir une visualisation

  1. Cliquez sur Fichier > Ouvrir.

  2. Entrez le nom d'une visualisation dans le champ de recherche, ou cliquez sur les flèches < et > pour naviguer entre les différentes pages. Le résultat peut également être filtré par type et par propriétaire en utilisant les menus correspondants dans le coin supérieur droit.

  3. Cliquez sur le nom de celle que vous voulez ouvrir.

Enregistrer une visualisation

  1. a) Cliquez sur Fichier > Enregistrer.

  2. Entrez un Nom et une Description pour votre visualisation.

  3. Cliquez sur Sauvegarder.

Renommer une visualisation

  1. Cliquez sur Fichier > Renommer.

  2. Entrez le nouveau nom et/ou une description.

  3. Cliquez sur Renommer.

Supprimer une visualisation

  1. Cliquez sur Fichier > Supprimer.

  2. Cliquez sur Supprimer.

  1. Cliquez sur Fichier > Obtenir le lien.

  2. Vous pouvez copier l'URL via le menu contextuel du navigateur qui s'ouvre lorsque vous faites un clic droit sur le lien.

Les interprétations de la visualisation

Lorsque vous affichez une visualisation enregistrée, vous pouvez élargir les interprétations sur le côté droit en cliquant sur le bouton Interprétations dans le coin supérieur droit. La description de la visualisation s'affichera également. La description prend en charge le Format Texte Enrichi.

De nouvelles interprétations peuvent être ajoutées en entrant dans le champ texte en bas à droite. Les autres utilisateurs peuvent être mentionnés avec @nom d'utilisateur. Commencez par taper @ plus les premières lettres du nom d'utilisateur ou du nom réel et une liste des utilisateurs correspondants s'affichera. Les utilisateurs mentionnés recevront un message DHIS2 interne avec l'interprétation ou le commentaire. Les interprétations peuvent également être consultées dans l'application Tableau de bord.

Il est possible de formater le texte avec gras, italique en utilisant les marqueurs de style Markdown * et _ pour gras et italique respectivement (des raccourcis clavier sont également disponibles : Ctrl/Cmd + B et Ctrl/Cmd + I). Un ensemble limité de smileys est pris en charge et peut être utilisé en tapant l'une des combinaisons de caractères suivantes : :) :-) :( :-( :+1 :-1. Les URL sont automatiquement détectées et converties en un lien cliquable.

Pour afficherer la visualisation en fonction de la date d'une interprétation donnée, cliquez sur l'interprétation ou sur son bouton Voir. Cela régénérera la visualisation avec la date correspondante, qui est indiquée à côté du titre de la visualisation. En cliquant sur Retour à toutes les interprétations, la visualisation sera régénérée avec la date actuelle.

Pour souscrire à la visualisation sauvegardée, cliquez sur l'icône de la cloche dans le coin supérieur droit. Vous recevrez alors des messages internes chaque fois qu'un autre utilisateur appréciera, créera ou mettra à jour une interprétation dans cette visualisation sauvegardée.

Partager une visualisation

Vous pouvez accéder aux paramètres de partage en cliquant sur Fichier > Partager. Modifiez les paramètres de partage pour les groupes d'utilisateurs que vous souhaitez modifier. Les paramètres disponibles sont les suivants :

  • Peut modifier et visualiser : Peut afficher et modifier la visualisation.

  • Peut seulement visualiser : Peut seulement voir la visualisation.

  • Pas d'accès : Vous n'aurez pas accès à la visualisation. Ce paramètre ne s'applique qu'à l'accès public et l'accès externe. (Notez que pour permettre l'accès à tout le monde, Accès public et Accès externe doivent tous deux être définis de manière à autoriser la visualisation).

Les nouveaux utilisateurs peuvent être ajoutés en les recherchant par leur nom sous Ajouter des utilisateurs et des groupes d'utilisateurs.

Télécharger

Les visualisations peuvent être téléchargées à partir du menu Télécharger. Tous les types de visualisation supportent les téléchargements sous forme de Graphique et de Source de donnée brute, à l'exception Tableau croisé dynamique, qui peut être téléchargé sous forme de Mise en page du tableau et Source de donnée brute.

Téléchargement sous forme de Graphique

Télécharge une image (.png) ou un fichier PDF (.pdf) sur votre ordinateur.

Téléchargement sous forme de Mise en page du tableau

Télécharge un fichier Excel (.xls), CSV (.csv) ou HTML (.html) sur votre ordinateur.

Téléchargement sous forme de Source de donnée brute

Vous pouvez télécharger les sources de données d'une visualisation au format JSON, XML, Excel, CSV, JXRML, formats de données brutes SQL avec différents clés d'identification (ID, code et nom). Le document de données utilise des identifiants des léments de dimension et ouvre une nouvelle fenêtre de navigateur pour afficher l'URL de la demande à l'API Web dans la barre d'adresse. Ceci est utile pour les développeurs d'applications et d'autres modules clients basés sur DHIS2 Web API ou pour ceux qui ont besoin d'une source de données du plan, par exemple pour l'importation à des fins statistiques.

Formats disponibles

Format Action Description
JSON Cliquez sur JSON Télécharge le format JSON selon la propriété ID, Code ou Nom.
XML Cliquez sur XML Télécharge le format XML selon la propriété ID, Code ou Nom.
Microsoft Excel Cliquez sur Microsoft Excel Télécharge le format Microsoft Excel selon la propriété ID, Code ou Nom.
CSV Click CSV Télécharge le format CSV selon la propriété ID, Code ou Nom.
Ensemble de valeurs de données XML Cliquez sur Avancé > XML Télécharge les valeurs des données brutes en XML, par opposition aux données agrégées selon diverses dimensions.
Ensemble de valeurs des données JSON Cliquez sur Avancé > JSON Télécharge les valeurs des données brutes en JSON, par opposition aux données agrégées selon diverses dimensions.
JRXML Cliquez sur Avancé > JRXML Produit un modèle de rapport Jasper pouvant être personnalisé en fonction de vos besoins spécifiques et utilisé comme base d'un rapport standard dans le système DHIS 2.
Données brutes SQL Cliquez sur Avancé > Données brutes SQL Fournit la véritable instruction SQL utilisée pour générer la visualisation des données. Vous pouvez l'utiliser comme source de données dans un rapport Jasper, ou comme base d'une vue SQL.

Voir la visualisation sous forme de carte

Pour avoir un aperçu d'une visualisation sur une carte, sélectionnez le type de visualisation Ouvrir comme carte une fois que vous avez fini d'élaborer votre visualisation.